Merge pull request #609 from LNP-BP/refactor-deps
[rust-lightning] / lightning-net-tokio / Cargo.toml
index adfedea7bcc2666e46a1d5740eef70f03752ef02..bdcb911395d939e31229a24b9b9851feb939d82d 100644 (file)
@@ -10,10 +10,8 @@ For Rust-Lightning clients which wish to make direct connections to Lightning P2
 """
 
 [dependencies]
-bitcoin = "0.21"
-bitcoin_hashes = "0.7"
+bitcoin = "0.23"
 lightning = { version = "0.0.11", path = "../lightning" }
-secp256k1 = "0.15"
 tokio = { version = ">=0.2.12", features = [ "io-util", "macros", "rt-core", "sync", "tcp", "time" ] }
 
 [dev-dependencies]