Rename no_std feature to no-std
[rust-lightning] / lightning / Cargo.toml
index 8bbdfe95a3ebdc138916e435bae85a1f0a3380e7..8580a53a3f88bf87bc698de0fed906a881dfa376 100644 (file)
@@ -26,14 +26,14 @@ max_level_debug = []
 unsafe_revoked_tx_signing = []
 unstable = []
 
-no_std = ["hashbrown", "bitcoin/no-std", "core2/alloc"]
+no-std = ["hashbrown", "bitcoin/no-std", "core2/alloc"]
 std = ["bitcoin/std"]
 
 default = ["std"]
 
 [dependencies]
 bitcoin = { version = "0.27", default-features = false, features = ["secp-recovery"] }
-# TODO maybe bitcoin no-std should pull in this feature?
+# TODO remove this once rust-bitcoin PR #637 is released
 secp256k1 = { version = "0.20.2", default-features = false, features = ["alloc"] }
 
 hashbrown = { version = "0.11", optional = true }
@@ -45,6 +45,7 @@ core2 = { version = "0.3.0", optional = true, default-features = false }
 [dev-dependencies]
 hex = "0.3"
 regex = "0.1.80"
+# TODO remove this once rust-bitcoin PR #637 is released
 secp256k1 = { version = "0.20.2", default-features = false, features = ["alloc"] }
 
 [dev-dependencies.bitcoin]