Bump dependencies to bitcoin 0.27 and bech32 0.8
[rust-lightning] / lightning / Cargo.toml
index 32c0d0af63403aaf34676465790c6697cd8f9fd5..9a2861d6927da1969955c7b01f06877e5c95dafa 100644 (file)
@@ -26,13 +26,13 @@ max_level_debug = []
 unsafe_revoked_tx_signing = []
 unstable = []
 
-no_std = ["hashbrown"]
-std = []
+no_std = ["hashbrown", "bitcoin/no-std"]
+std = ["bitcoin/std"]
 
 default = ["std"]
 
 [dependencies]
-bitcoin = "0.26"
+bitcoin = "0.27"
 
 hashbrown = { version = "0.11", optional = true }
 hex = { version = "0.3", optional = true }
@@ -43,7 +43,7 @@ hex = "0.3"
 regex = "0.1.80"
 
 [dev-dependencies.bitcoin]
-version = "0.26"
+version = "0.27"
 features = ["bitcoinconsensus"]
 
 [package.metadata.docs.rs]