Add a relatively simple mostly-const-fn bigint math implementation
[dnssec-prover] / fuzz / Cargo.toml
index b8869bda4d2697ed4a9f81ee313b8fbbe6c2ebb1..74a5929ed409a04fd37fea16b9172805d484a8d3 100644 (file)
@@ -18,7 +18,7 @@ libfuzzer_fuzz = ["libfuzzer-sys"]
 stdin_fuzz = []
 
 [dependencies]
-dnssec-prover = { path = "../", features = ["validation", "std", "build_server"] }
+dnssec-prover = { path = "../", features = ["validation", "std", "build_server", "ibig"] }
 
 afl = { version = "0.12", optional = true }
 honggfuzz = { version = "0.5", optional = true, default-features = false }
@@ -52,3 +52,7 @@ path = "src/parse_stream_validate.rs"
 [[bin]]
 name = "fuzz_builder"
 path = "src/fuzz_builder.rs"
+
+[[bin]]
+name = "bigint_math"
+path = "src/bigint_math.rs"