Update CI/Cargo.toml references to 0.0.122
[ldk-c-bindings] / lightning-c-bindings / Cargo.toml
index ad72f40d3dbe597f57df3172c8b3bdf2f5199b74..cc632ab3a731ba88a0765ed68dd4b8f1d23fe05c 100644 (file)
@@ -15,18 +15,18 @@ crate-type = ["staticlib"
 ,"cdylib"]
 
 [features]
 ,"cdylib"]
 
 [features]
-no-std = ["bitcoin/no-std", "lightning/no-std", "lightning-invoice/no-std", "core2"]
-std = ["bitcoin/std", "lightning/std", "lightning-invoice/std"]
+no-std = ["bitcoin/no-std", "lightning/no-std", "lightning-invoice/no-std", "lightning-background-processor/no-std", "core2"]
+std = ["bitcoin/std", "lightning/std", "lightning-invoice/std", "lightning-background-processor/std"]
 
 [dependencies]
 
 [dependencies]
-bitcoin = { version = "0.28", default-features = false }
-secp256k1 = { version = "0.22", features = ["global-context", "recovery"] }
+bitcoin = { version = "0.30", default-features = false }
+secp256k1 = { version = "0.27", features = ["global-context", "recovery"] }
 # Note that the following line is matched by genbindings to update the path
 # Note that the following line is matched by genbindings to update the path
-lightning = { git = "https://github.com/lightningdevkit/rust-lightning", branch = "0.0.108-bindings", default-features = false }
-lightning-persister = { git = "https://github.com/lightningdevkit/rust-lightning", branch = "0.0.108-bindings", default-features = false }
-lightning-invoice = { git = "https://github.com/lightningdevkit/rust-lightning", branch = "0.0.108-bindings", default-features = false }
-lightning-background-processor = { git = "https://github.com/lightningdevkit/rust-lightning", branch = "0.0.108-bindings", default-features = false }
-lightning-rapid-gossip-sync = { git = "https://github.com/lightningdevkit/rust-lightning", branch = "0.0.108-bindings", default-features = false }
+lightning = { git = "https://github.com/lightningdevkit/rust-lightning", branch = "0.0.122-bindings", default-features = false }
+lightning-persister = { git = "https://github.com/lightningdevkit/rust-lightning", branch = "0.0.122-bindings", default-features = false }
+lightning-invoice = { git = "https://github.com/lightningdevkit/rust-lightning", branch = "0.0.122-bindings", default-features = false }
+lightning-background-processor = { git = "https://github.com/lightningdevkit/rust-lightning", branch = "0.0.122-bindings", default-features = false }
+lightning-rapid-gossip-sync = { git = "https://github.com/lightningdevkit/rust-lightning", branch = "0.0.122-bindings", default-features = false }
 
 core2 = { version = "0.3.0", optional = true, default-features = false }
 
 
 core2 = { version = "0.3.0", optional = true, default-features = false }