Update bindings workflow in CI to 0.0.106
[ldk-c-bindings] / lightning-c-bindings / Cargo.toml
index 1f26f39d5ce2cca9278b24001f84b0bb41a15ff4..3c77e22f7eb43908532bc98169153eafb5d86720 100644 (file)
@@ -14,14 +14,20 @@ crate-type = ["staticlib"
 # Note that the following line is matched exactly by genbindings to turn off dylib creation
 ,"cdylib"]
 
+[features]
+no-std = ["bitcoin/no-std", "lightning/no-std", "lightning-invoice/no-std", "core2"]
+std = ["bitcoin/std", "lightning/std", "lightning-invoice/std"]
+
 [dependencies]
-bitcoin = "0.27"
+bitcoin = { version = "0.27", default-features = false }
 secp256k1 = { version = "0.20.3", features = ["global-context-less-secure"] }
 # Note that the following line is matched by genbindings to update the path
-lightning = { git = "https://github.com/rust-bitcoin/rust-lightning", rev = "50b1017fca4c7b73f9dc71ed923e91c6c1da6459", features = ["allow_wallclock_use"] }
-lightning-persister = { git = "https://github.com/rust-bitcoin/rust-lightning", rev = "50b1017fca4c7b73f9dc71ed923e91c6c1da6459" }
-lightning-invoice = { git = "https://github.com/rust-bitcoin/rust-lightning", rev = "50b1017fca4c7b73f9dc71ed923e91c6c1da6459" }
-lightning-background-processor = { git = "https://github.com/rust-bitcoin/rust-lightning", rev = "50b1017fca4c7b73f9dc71ed923e91c6c1da6459" }
+lightning = { git = "https://github.com/lightningdevkit/rust-lightning", branch = "0.0.106-bindings", default-features = false }
+lightning-persister = { git = "https://github.com/lightningdevkit/rust-lightning", branch = "0.0.106-bindings", default-features = false }
+lightning-invoice = { git = "https://github.com/lightningdevkit/rust-lightning", branch = "0.0.106-bindings", default-features = false }
+lightning-background-processor = { git = "https://github.com/lightningdevkit/rust-lightning", branch = "0.0.106-bindings", default-features = false }
+
+core2 = { version = "0.3.0", optional = true, default-features = false }
 
 # Always force panic=abort, further options are set in the genbindings.sh build script
 [profile.dev]