Implement conversion of std::io::Error to Rust
[ldk-c-bindings] / lightning-c-bindings / Cargo.toml
index 788cff11544be6424a908d1e96209517ce681a26..40d316ede15ebaa4557afbcd77d60c232605414b 100644 (file)
@@ -18,7 +18,9 @@ crate-type = ["staticlib"
 bitcoin = "0.26"
 secp256k1 = { version = "0.20.1", features = ["global-context-less-secure"] }
 # Note that the following line is matched by genbindings to update the path
-lightning = { git = "https://git.bitcoin.ninja/rust-lightning", rev = "8088e4ba1505c026ac91f8c1489fb7d53d6b656e", features = ["allow_wallclock_use"] }
+lightning = { git = "https://git.bitcoin.ninja/rust-lightning", rev = "3996eaab6e2eaf5fde9374b51d952c0edef5ea92", features = ["allow_wallclock_use"] }
+lightning-persister = { git = "https://git.bitcoin.ninja/rust-lightning", rev = "3996eaab6e2eaf5fde9374b51d952c0edef5ea92" }
+lightning-invoice = { git = "https://git.bitcoin.ninja/rust-lightning", rev = "3996eaab6e2eaf5fde9374b51d952c0edef5ea92" }
 
 [patch.crates-io]
 # Rust-Secp256k1 PR 279. Should be dropped once merged.