Update rust-secp patch to match latest version
[ldk-c-bindings] / lightning-c-bindings / Cargo.toml
index 40d316ede15ebaa4557afbcd77d60c232605414b..75c28917f9991beadf6c1a3cf27b310dc092877e 100644 (file)
@@ -21,10 +21,11 @@ secp256k1 = { version = "0.20.1", features = ["global-context-less-secure"] }
 lightning = { git = "https://git.bitcoin.ninja/rust-lightning", rev = "3996eaab6e2eaf5fde9374b51d952c0edef5ea92", features = ["allow_wallclock_use"] }
 lightning-persister = { git = "https://git.bitcoin.ninja/rust-lightning", rev = "3996eaab6e2eaf5fde9374b51d952c0edef5ea92" }
 lightning-invoice = { git = "https://git.bitcoin.ninja/rust-lightning", rev = "3996eaab6e2eaf5fde9374b51d952c0edef5ea92" }
+lightning-background-processor = { git = "https://git.bitcoin.ninja/rust-lightning", rev = "3996eaab6e2eaf5fde9374b51d952c0edef5ea92" }
 
 [patch.crates-io]
-# Rust-Secp256k1 PR 279. Should be dropped once merged.
-secp256k1 = { git = 'https://github.com/TheBlueMatt/rust-secp256k1', rev = '50bf9e48ca0f0d267c41e729520a2673ecfaa84f' }
+# Rust-Secp256k1 upstream to get PR 279 until it is released.
+secp256k1 = { git = 'https://github.com/TheBlueMatt/rust-secp256k1' }
 
 # Always force panic=abort, further options are set in the genbindings.sh build script
 [profile.dev]