Merge pull request #51 from TheBlueMatt/main
[ldk-c-bindings] / lightning-c-bindings / Cargo.toml
index d783b08f9e264b3c99cec95c1fb3c39e7a73c06a..784422c36520d6d48e2e0005313eeba9eb716801 100644 (file)
@@ -18,10 +18,10 @@ crate-type = ["staticlib"
 bitcoin = "0.27"
 secp256k1 = { version = "0.20.3", features = ["global-context-less-secure"] }
 # Note that the following line is matched by genbindings to update the path
-lightning = { git = "https://github.com/rust-bitcoin/rust-lightning", rev = "3c5d1bf5844477d7b77e4b5dbb5d65586ae3b192", features = ["allow_wallclock_use"] }
-lightning-persister = { git = "https://github.com/rust-bitcoin/rust-lightning", rev = "3c5d1bf5844477d7b77e4b5dbb5d65586ae3b192" }
-lightning-invoice = { git = "https://github.com/rust-bitcoin/rust-lightning", rev = "3c5d1bf5844477d7b77e4b5dbb5d65586ae3b192" }
-lightning-background-processor = { git = "https://github.com/rust-bitcoin/rust-lightning", rev = "3c5d1bf5844477d7b77e4b5dbb5d65586ae3b192" }
+lightning = { git = "https://github.com/lightningdevkit/rust-lightning", rev = "80ea2e51cdd3decf084574dee365065d782f7e8c", features = ["std"] }
+lightning-persister = { git = "https://github.com/lightningdevkit/rust-lightning", rev = "80ea2e51cdd3decf084574dee365065d782f7e8c" }
+lightning-invoice = { git = "https://github.com/lightningdevkit/rust-lightning", rev = "80ea2e51cdd3decf084574dee365065d782f7e8c" }
+lightning-background-processor = { git = "https://github.com/lightningdevkit/rust-lightning", rev = "80ea2e51cdd3decf084574dee365065d782f7e8c" }
 
 # Always force panic=abort, further options are set in the genbindings.sh build script
 [profile.dev]