Switch rust-lightning dep to upstream now that we're "stable"
[ldk-c-bindings] / lightning-c-bindings / Cargo.toml
index 0b20e3f6cc4d9f8b034340486651def3067836f2..93e4d86e57eef64f6cbe182123eeb2736560105f 100644 (file)
@@ -18,11 +18,14 @@ crate-type = ["staticlib"
 bitcoin = "0.26"
 secp256k1 = { version = "0.20.1", features = ["global-context-less-secure"] }
 # Note that the following line is matched by genbindings to update the path
-lightning = { git = "https://github.com/rust-bitcoin/rust-lightning", rev = "8b4ea56966878140b11aa3e17b44fcf1e01d6413" }
+lightning = { git = "https://github.com/rust-bitcoin/rust-lightning", rev = "294009969aef617df4184ff41ef6daa5a445f213", features = ["allow_wallclock_use"] }
+lightning-persister = { git = "https://github.com/rust-bitcoin/rust-lightning", rev = "294009969aef617df4184ff41ef6daa5a445f213" }
+lightning-invoice = { git = "https://github.com/rust-bitcoin/rust-lightning", rev = "294009969aef617df4184ff41ef6daa5a445f213" }
+lightning-background-processor = { git = "https://github.com/rust-bitcoin/rust-lightning", rev = "294009969aef617df4184ff41ef6daa5a445f213" }
 
 [patch.crates-io]
-# Rust-Secp256k1 PR 279. Should be dropped once merged.
-secp256k1 = { git = 'https://github.com/TheBlueMatt/rust-secp256k1', rev = '15a0d4195a20355f6b1e8f54c84eba56abc15cbd' }
+# Rust-Secp256k1 upstream to get PR 279 until it is released.
+secp256k1 = { git = 'https://github.com/TheBlueMatt/rust-secp256k1' }
 
 # Always force panic=abort, further options are set in the genbindings.sh build script
 [profile.dev]