Update lightning-c-bindings crate rev to current upstream
[ldk-c-bindings] / lightning-c-bindings / Cargo.toml
index 76047314ea148ad27d667ec63155a2f91a43bde8..96bd1252fa7eb56acf92f9bcb31fa946ced41aac 100644 (file)
@@ -17,7 +17,8 @@ crate-type = ["staticlib"
 [dependencies]
 bitcoin = "0.26"
 secp256k1 = { version = "0.20.1", features = ["global-context-less-secure"] }
-lightning = { version = "0.0.12", path = "../lightning" }
+# Note that the following line is matched by genbindings to update the path
+lightning = { git = "https://github.com/rust-bitcoin/rust-lightning", rev = "c9321c5ec07ee2daa895b5136e9472a42d4eff1d" }
 
 [patch.crates-io]
 # Rust-Secp256k1 PR 279. Should be dropped once merged.
@@ -29,8 +30,3 @@ panic = "abort"
 
 [profile.release]
 panic = "abort"
-
-# We eventually want to join the root workspace, but for now, the bindings generation is
-# a bit brittle and we don't want to hold up other developers from making changes just
-# because they break the bindings
-[workspace]