Update lightning-c-bindings Cargo and CI to reference 0.0.110
[ldk-c-bindings] / lightning-c-bindings / Cargo.toml
index e8e556b58afa352488e10954613ea721f6db8272..be1db7e1467760aba335f94e251e8917dd1d7b13 100644 (file)
@@ -14,15 +14,21 @@ crate-type = ["staticlib"
 # Note that the following line is matched exactly by genbindings to turn off dylib creation
 ,"cdylib"]
 
+[features]
+no-std = ["bitcoin/no-std", "lightning/no-std", "lightning-invoice/no-std", "core2"]
+std = ["bitcoin/std", "lightning/std", "lightning-invoice/std"]
+
 [dependencies]
-bitcoin = "0.26"
-secp256k1 = { version = "0.20.1", features = ["global-context-less-secure"] }
+bitcoin = { version = "0.28", default-features = false }
+secp256k1 = { version = "0.22", features = ["global-context", "recovery"] }
 # Note that the following line is matched by genbindings to update the path
-lightning = { git = "https://git.bitcoin.ninja/rust-lightning", rev = "6fcac8bc65ed6d372e0b8c367e9934c754f99ff3", features = ["allow_wallclock_use"] }
+lightning = { git = "https://github.com/lightningdevkit/rust-lightning", branch = "0.0.110-bindings", default-features = false }
+lightning-persister = { git = "https://github.com/lightningdevkit/rust-lightning", branch = "0.0.110-bindings", default-features = false }
+lightning-invoice = { git = "https://github.com/lightningdevkit/rust-lightning", branch = "0.0.110-bindings", default-features = false }
+lightning-background-processor = { git = "https://github.com/lightningdevkit/rust-lightning", branch = "0.0.110-bindings", default-features = false }
+lightning-rapid-gossip-sync = { git = "https://github.com/lightningdevkit/rust-lightning", branch = "0.0.110-bindings", default-features = false }
 
-[patch.crates-io]
-# Rust-Secp256k1 PR 279. Should be dropped once merged.
-secp256k1 = { git = 'https://github.com/TheBlueMatt/rust-secp256k1', rev = '15a0d4195a20355f6b1e8f54c84eba56abc15cbd' }
+core2 = { version = "0.3.0", optional = true, default-features = false }
 
 # Always force panic=abort, further options are set in the genbindings.sh build script
 [profile.dev]