Merge pull request #46 from TheBlueMatt/main
[ldk-c-bindings] / lightning-c-bindings / Cargo.toml
index 93e4d86e57eef64f6cbe182123eeb2736560105f..e2e5a1ef21d81f21f4e3eb41be0d0089a90f768e 100644 (file)
@@ -15,17 +15,13 @@ crate-type = ["staticlib"
 ,"cdylib"]
 
 [dependencies]
-bitcoin = "0.26"
-secp256k1 = { version = "0.20.1", features = ["global-context-less-secure"] }
+bitcoin = "0.27"
+secp256k1 = { version = "0.20.3", features = ["global-context-less-secure"] }
 # Note that the following line is matched by genbindings to update the path
-lightning = { git = "https://github.com/rust-bitcoin/rust-lightning", rev = "294009969aef617df4184ff41ef6daa5a445f213", features = ["allow_wallclock_use"] }
-lightning-persister = { git = "https://github.com/rust-bitcoin/rust-lightning", rev = "294009969aef617df4184ff41ef6daa5a445f213" }
-lightning-invoice = { git = "https://github.com/rust-bitcoin/rust-lightning", rev = "294009969aef617df4184ff41ef6daa5a445f213" }
-lightning-background-processor = { git = "https://github.com/rust-bitcoin/rust-lightning", rev = "294009969aef617df4184ff41ef6daa5a445f213" }
-
-[patch.crates-io]
-# Rust-Secp256k1 upstream to get PR 279 until it is released.
-secp256k1 = { git = 'https://github.com/TheBlueMatt/rust-secp256k1' }
+lightning = { git = "https://github.com/rust-bitcoin/rust-lightning", rev = "001bc7113a92a586e7e7ac4557bbae7a1a402550", features = ["allow_wallclock_use"] }
+lightning-persister = { git = "https://github.com/rust-bitcoin/rust-lightning", rev = "001bc7113a92a586e7e7ac4557bbae7a1a402550" }
+lightning-invoice = { git = "https://github.com/rust-bitcoin/rust-lightning", rev = "001bc7113a92a586e7e7ac4557bbae7a1a402550" }
+lightning-background-processor = { git = "https://github.com/rust-bitcoin/rust-lightning", rev = "001bc7113a92a586e7e7ac4557bbae7a1a402550" }
 
 # Always force panic=abort, further options are set in the genbindings.sh build script
 [profile.dev]