Merge pull request #46 from TheBlueMatt/main
[ldk-c-bindings] / lightning-c-bindings / Cargo.toml
index 96bd1252fa7eb56acf92f9bcb31fa946ced41aac..e2e5a1ef21d81f21f4e3eb41be0d0089a90f768e 100644 (file)
@@ -15,14 +15,13 @@ crate-type = ["staticlib"
 ,"cdylib"]
 
 [dependencies]
-bitcoin = "0.26"
-secp256k1 = { version = "0.20.1", features = ["global-context-less-secure"] }
+bitcoin = "0.27"
+secp256k1 = { version = "0.20.3", features = ["global-context-less-secure"] }
 # Note that the following line is matched by genbindings to update the path
-lightning = { git = "https://github.com/rust-bitcoin/rust-lightning", rev = "c9321c5ec07ee2daa895b5136e9472a42d4eff1d" }
-
-[patch.crates-io]
-# Rust-Secp256k1 PR 279. Should be dropped once merged.
-secp256k1 = { git = 'https://github.com/TheBlueMatt/rust-secp256k1', rev = '15a0d4195a20355f6b1e8f54c84eba56abc15cbd' }
+lightning = { git = "https://github.com/rust-bitcoin/rust-lightning", rev = "001bc7113a92a586e7e7ac4557bbae7a1a402550", features = ["allow_wallclock_use"] }
+lightning-persister = { git = "https://github.com/rust-bitcoin/rust-lightning", rev = "001bc7113a92a586e7e7ac4557bbae7a1a402550" }
+lightning-invoice = { git = "https://github.com/rust-bitcoin/rust-lightning", rev = "001bc7113a92a586e7e7ac4557bbae7a1a402550" }
+lightning-background-processor = { git = "https://github.com/rust-bitcoin/rust-lightning", rev = "001bc7113a92a586e7e7ac4557bbae7a1a402550" }
 
 # Always force panic=abort, further options are set in the genbindings.sh build script
 [profile.dev]