Adopting new bitcoin hash types and crate version
[rust-lightning] / fuzz / Cargo.toml
index 39f805d44ee404280547a32a3bfc12225f8f3c4f..115f3e8a4dc0db632cf417b0ae840051da4c783d 100644 (file)
@@ -3,6 +3,9 @@ name = "lightning-fuzz"
 version = "0.0.1"
 authors = ["Automatically generated"]
 publish = false
+# Because the function is unused it gets dropped before we link lightning, so
+# we have to duplicate build.rs here. Note that this is only required for
+# fuzztarget mode.
 
 [package.metadata]
 cargo-fuzz = true
@@ -10,27 +13,33 @@ cargo-fuzz = true
 [features]
 afl_fuzz = ["afl"]
 honggfuzz_fuzz = ["honggfuzz"]
+libfuzzer_fuzz = ["libfuzzer-sys"]
+stdin_fuzz = []
 
 [dependencies]
-lightning = { path = "..", features = ["fuzztarget"] }
-bitcoin = { git = "https://github.com/rust-bitcoin/rust-bitcoin", features = ["fuzztarget"] }
-secp256k1 = { version = "0.9", features = ["fuzztarget"] }
-rust-crypto = "0.2"
+afl = { version = "0.4", optional = true }
+lightning = { path = "../lightning", features = ["fuzztarget"] }
+bitcoin = { version = "0.23", features = ["fuzztarget"] }
+hex = "0.3"
 honggfuzz = { version = "0.5", optional = true }
-afl = { version = "0.3", optional = true }
+libfuzzer-sys = { git = "https://github.com/rust-fuzz/libfuzzer-sys.git", optional = true }
+
+[build-dependencies]
+cc = "1.0"
 
 # Prevent this from interfering with workspaces
 [workspace]
 members = ["."]
 
-[[bin]]
-name = "peer_crypt_target"
-path = "fuzz_targets/peer_crypt_target.rs"
+[profile.release]
+lto = true
+codegen-units = 1
 
-[[bin]]
-name = "channel_target"
-path = "fuzz_targets/channel_target.rs"
+# When testing a large fuzz corpus, -O1 offers a nice speedup
+[profile.dev]
+opt-level = 1
 
-[[bin]]
-name = "full_stack_target"
-path = "fuzz_targets/full_stack_target.rs"
+[lib]
+name = "lightning_fuzz"
+path = "src/lib.rs"
+crate-type = ["rlib", "dylib", "staticlib"]