Thread fuzz test cases
[rust-lightning] / fuzz / Cargo.toml
index 22a6e2156491e3445f7deeb48f318a10c94a9212..5e3197f8f8f1929c1c35270dd872f6f964130bca 100644 (file)
@@ -19,7 +19,7 @@ stdin_fuzz = []
 [dependencies]
 afl = { version = "0.4", optional = true }
 lightning = { path = "../lightning", features = ["fuzztarget"] }
-bitcoin = { version = "0.20", features = ["fuzztarget"] }
+bitcoin = { version = "0.21", features = ["fuzztarget"] }
 bitcoin_hashes = { version = "0.7", features = ["fuzztarget"] }
 hex = "0.3"
 honggfuzz = { version = "0.5", optional = true }
@@ -37,6 +37,10 @@ members = ["."]
 lto = true
 codegen-units = 1
 
+# When testing a large fuzz corpus, -O1 offers a nice speedup
+[profile.dev]
+opt-level = 1
+
 [lib]
 name = "lightning_fuzz"
 path = "src/lib.rs"