Implement BlockSource for REST and RPC clients
[rust-lightning] / lightning-block-sync / Cargo.toml
index f2032b05c3a8bd4081f5e2601249d869fa8d142b..aec6d1404c098f0fe4b58b6af73ba40e6299e503 100644 (file)
@@ -9,13 +9,14 @@ Utilities to fetch the chain data from a block source and feed them into Rust Li
 """
 
 [features]
-rest-client = [ "serde_json", "chunked_transfer" ]
-rpc-client = [ "serde_json", "chunked_transfer" ]
+rest-client = [ "serde", "serde_json", "chunked_transfer" ]
+rpc-client = [ "serde", "serde_json", "chunked_transfer" ]
 
 [dependencies]
 bitcoin = "0.24"
 lightning = { version = "0.0.12", path = "../lightning" }
 tokio = { version = "1.0", features = [ "io-util", "net" ], optional = true }
+serde = { version = "1.0", features = ["derive"], optional = true }
 serde_json = { version = "1.0", optional = true }
 chunked_transfer = { version = "1.4", optional = true }
 futures = { version = "0.3" }