Bump most crate versions to 0.0.99 and lightning-invoice to 0.7.0
[rust-lightning] / lightning-block-sync / Cargo.toml
index 547b04d71b7188839e5e1524792a642ae423d38d..b72d91cda5087592690f95c1bc4cb91ff1c9e159 100644 (file)
@@ -1,13 +1,26 @@
 [package]
 name = "lightning-block-sync"
-version = "0.0.1"
+version = "0.0.99"
 authors = ["Jeffrey Czyz", "Matt Corallo"]
-license = "Apache-2.0"
-edition = "2018"
+license = "MIT OR Apache-2.0"
+repository = "http://github.com/rust-bitcoin/rust-lightning"
 description = """
 Utilities to fetch the chain data from a block source and feed them into Rust Lightning.
 """
+edition = "2018"
+
+[features]
+rest-client = [ "serde", "serde_json", "chunked_transfer" ]
+rpc-client = [ "serde", "serde_json", "chunked_transfer" ]
 
 [dependencies]
-bitcoin = "0.24"
-lightning = { version = "0.0.12", path = "../lightning" }
+bitcoin = "0.26"
+lightning = { version = "0.0.99", path = "../lightning" }
+tokio = { version = "1.0", features = [ "io-util", "net", "time" ], optional = true }
+serde = { version = "1.0", features = ["derive"], optional = true }
+serde_json = { version = "1.0", optional = true }
+chunked_transfer = { version = "1.4", optional = true }
+futures = { version = "0.3" }
+
+[dev-dependencies]
+tokio = { version = "1.0", features = [ "macros", "rt" ] }