[bindings] Build a wasm32-wasi library in genbindings.sh
[rust-lightning] / lightning-c-bindings / Cargo.toml
index 9f7210386b629ad4c10be009129a8673180a1bff..76047314ea148ad27d667ec63155a2f91a43bde8 100644 (file)
@@ -23,6 +23,13 @@ lightning = { version = "0.0.12", path = "../lightning" }
 # Rust-Secp256k1 PR 279. Should be dropped once merged.
 secp256k1 = { git = 'https://github.com/TheBlueMatt/rust-secp256k1', rev = '15a0d4195a20355f6b1e8f54c84eba56abc15cbd' }
 
+# Always force panic=abort, further options are set in the genbindings.sh build script
+[profile.dev]
+panic = "abort"
+
+[profile.release]
+panic = "abort"
+
 # We eventually want to join the root workspace, but for now, the bindings generation is
 # a bit brittle and we don't want to hold up other developers from making changes just
 # because they break the bindings