Remove the bindings crate from the root namespace to let it break
[rust-lightning] / lightning-c-bindings / Cargo.toml
index 8280f35685c80116db18b32b0374bbbcba2611b6..7e4a403e23f9ed9fa3d81b5d7d6f1e2e741f13bc 100644 (file)
@@ -17,3 +17,8 @@ crate-type = ["staticlib"
 [dependencies]
 bitcoin = "0.24"
 lightning = { version = "0.0.11", path = "../lightning" }
+
+# We eventually want to join the root workspace, but for now, the bindings generation is
+# a bit brittle and we don't want to hold up other developers from making changes just
+# because they break the bindings
+[workspace]