Bump versions to 0.0.11/net-tokio 0.0.3
[rust-lightning] / lightning-net-tokio / Cargo.toml
index 3502410ad1e767f44190b3117efc4963222f6fde..adfedea7bcc2666e46a1d5740eef70f03752ef02 100644 (file)
@@ -1,19 +1,20 @@
 [package]
 name = "lightning-net-tokio"
-version = "0.0.1"
+version = "0.0.4"
 authors = ["Matt Corallo"]
 license = "Apache-2.0"
+edition = "2018"
 description = """
 Implementation of the rust-lightning network stack using Tokio.
-For Rust-Lightning clients which wish to make direct connections to Lightning P2P nodes, this is a simple alternative to implementing the nerequired network stack, especially for those already using Tokio.
+For Rust-Lightning clients which wish to make direct connections to Lightning P2P nodes, this is a simple alternative to implementing the required network stack, especially for those already using Tokio.
 """
 
 [dependencies]
 bitcoin = "0.21"
 bitcoin_hashes = "0.7"
-lightning = { version = "0.0.9", path = "../lightning" }
+lightning = { version = "0.0.11", path = "../lightning" }
 secp256k1 = "0.15"
-tokio-codec = "0.1"
-futures = "0.1"
-tokio = "0.1"
-bytes = "0.4"
+tokio = { version = ">=0.2.12", features = [ "io-util", "macros", "rt-core", "sync", "tcp", "time" ] }
+
+[dev-dependencies]
+tokio = { version = ">=0.2.12", features = [ "io-util", "macros", "rt-core", "rt-threaded", "sync", "tcp", "time" ] }