Bump most crate versions to 0.0.99 and lightning-invoice to 0.7.0
[rust-lightning] / lightning-net-tokio / Cargo.toml
index adfedea7bcc2666e46a1d5740eef70f03752ef02..d855529fa9cb0aa1931a1011ccf7111aa4be6477 100644 (file)
@@ -1,20 +1,19 @@
 [package]
 name = "lightning-net-tokio"
-version = "0.0.4"
+version = "0.0.99"
 authors = ["Matt Corallo"]
-license = "Apache-2.0"
-edition = "2018"
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/rust-bitcoin/rust-lightning/"
 description = """
 Implementation of the rust-lightning network stack using Tokio.
 For Rust-Lightning clients which wish to make direct connections to Lightning P2P nodes, this is a simple alternative to implementing the required network stack, especially for those already using Tokio.
 """
+edition = "2018"
 
 [dependencies]
-bitcoin = "0.21"
-bitcoin_hashes = "0.7"
-lightning = { version = "0.0.11", path = "../lightning" }
-secp256k1 = "0.15"
-tokio = { version = ">=0.2.12", features = [ "io-util", "macros", "rt-core", "sync", "tcp", "time" ] }
+bitcoin = "0.26"
+lightning = { version = "0.0.99", path = "../lightning" }
+tokio = { version = "1.0", features = [ "io-util", "macros", "rt", "sync", "net", "time" ] }
 
 [dev-dependencies]
-tokio = { version = ">=0.2.12", features = [ "io-util", "macros", "rt-core", "rt-threaded", "sync", "tcp", "time" ] }
+tokio = { version = "1.0", features = [ "io-util", "macros", "rt", "rt-multi-thread", "sync", "net", "time" ] }