Bump most crate versions to 0.0.99 and lightning-invoice to 0.7.0
[rust-lightning] / lightning-persister / Cargo.toml
index 8eb889dd0d217fc4f0185a08fc997ec29ace1d54..9ce4e8f683fb20cb7e6daad7a49fb30ff7d1dd83 100644 (file)
@@ -1,23 +1,23 @@
 [package]
 name = "lightning-persister"
-version = "0.0.13"
+version = "0.0.99"
 authors = ["Valentine Wallace", "Matt Corallo"]
-license = "Apache-2.0"
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/rust-bitcoin/rust-lightning/"
 description = """
-Utilities to manage channel data persistence and retrieval.
+Utilities to manage Rust-Lightning channel data persistence and retrieval.
 """
 
+[features]
+unstable = ["lightning/unstable"]
+
 [dependencies]
 bitcoin = "0.26"
-lightning = { version = "0.0.13", path = "../lightning" }
+lightning = { version = "0.0.99", path = "../lightning" }
 libc = "0.2"
 
 [target.'cfg(windows)'.dependencies]
 winapi = { version = "0.3", features = ["winbase"] }
 
-[dev-dependencies.bitcoin]
-version = "0.26"
-features = ["bitcoinconsensus"]
-
 [dev-dependencies]
-lightning = { version = "0.0.13", path = "../lightning", features = ["_test_utils"] }
+lightning = { version = "0.0.99", path = "../lightning", features = ["_test_utils"] }