export "unsafe_revoked_tx_signing" feature
[rust-lightning] / lightning / Cargo.toml
index e1b9462668b1ac8f9348a479f918f3be11581a51..20a6460d62dfec24bfe84d7aaaf823395e5912fd 100644 (file)
@@ -18,6 +18,9 @@ max_level_error = []
 max_level_warn = []
 max_level_info = []
 max_level_debug = []
+# Allow signing of local transactions that may have been revoked or will be revoked, for functional testing (e.g. justice tx handling).
+# This is unsafe to use in production because it may result in the counterparty publishing taking our funds.
+unsafe_revoked_tx_signing = []
 
 [dependencies]
 bitcoin = "0.23"