Implement dummy Mutex, Condvar and RwLock
[rust-lightning] / lightning / Cargo.toml
index 7172ee07cb8e99204b83005310b6540ef649e442..32c0d0af63403aaf34676465790c6697cd8f9fd5 100644 (file)
@@ -25,7 +25,11 @@ max_level_debug = []
 # This is unsafe to use in production because it may result in the counterparty publishing taking our funds.
 unsafe_revoked_tx_signing = []
 unstable = []
+
 no_std = ["hashbrown"]
+std = []
+
+default = ["std"]
 
 [dependencies]
 bitcoin = "0.26"