Implement dummy Mutex, Condvar and RwLock
[rust-lightning] / lightning / Cargo.toml
index affe46e3d03e2606bc58ea2a74c9b8e7feb4bbc5..32c0d0af63403aaf34676465790c6697cd8f9fd5 100644 (file)
@@ -1,6 +1,6 @@
 [package]
 name = "lightning"
-version = "0.0.98"
+version = "0.0.99"
 authors = ["Matt Corallo"]
 license = "MIT OR Apache-2.0"
 repository = "https://github.com/rust-bitcoin/rust-lightning/"
@@ -26,9 +26,15 @@ max_level_debug = []
 unsafe_revoked_tx_signing = []
 unstable = []
 
+no_std = ["hashbrown"]
+std = []
+
+default = ["std"]
+
 [dependencies]
 bitcoin = "0.26"
 
+hashbrown = { version = "0.11", optional = true }
 hex = { version = "0.3", optional = true }
 regex = { version = "0.1.80", optional = true }