Run with mutagen on travis.
[rust-lightning] / lightning / Cargo.toml
index 004e6d25bbbebdcb0151a72a13912856cf59e18d..3be6b7d33701208f86260e96c39a73fdd0237155 100644 (file)
@@ -1,6 +1,6 @@
 [package]
 name = "lightning"
-version = "0.0.9"
+version = "0.0.11"
 authors = ["Matt Corallo"]
 license = "Apache-2.0"
 repository = "https://github.com/rust-bitcoin/rust-lightning/"
@@ -11,9 +11,6 @@ Still missing tons of error-handling. See GitHub issues for suggested projects i
 """
 
 [features]
-# Supports tracking channels with a non-bitcoin chain hashes. Currently enables all kinds of fun DoS attacks.
-non_bitcoin_chain_hash_routing = []
-fuzztarget = ["secp256k1/fuzztarget", "bitcoin/fuzztarget", "bitcoin_hashes/fuzztarget"]
 # Unlog messages superior at targeted level.
 max_level_off = []
 max_level_error = []
@@ -21,18 +18,18 @@ max_level_warn = []
 max_level_info = []
 max_level_debug = []
 
+# Testing only features, don't enable these unless you want to run rust-lightning tests!
+fuzztarget = ["bitcoin/fuzztarget"]
+mutation_testing = ["mutagen"]
+
 [dependencies]
-bitcoin = "0.20"
-bitcoin_hashes = "0.7"
-secp256k1 = "0.15"
+bitcoin = "0.23"
+mutagen = { git = "https://github.com/TheBlueMatt/mutagen", optional = true }
 
 [dev-dependencies.bitcoin]
-version = "0.20"
+version = "0.23"
 features = ["bitcoinconsensus"]
 
 [dev-dependencies]
 hex = "0.3"
 rand = "0.4"
-
-[profile.dev]
-opt-level = 1