Bump most crate versions to 0.0.99 and lightning-invoice to 0.7.0
[rust-lightning] / lightning / Cargo.toml
index f89b548184ccfcd76d66a9a1f46f092359fe04d7..7172ee07cb8e99204b83005310b6540ef649e442 100644 (file)
@@ -1,8 +1,8 @@
 [package]
 name = "lightning"
-version = "0.0.11"
+version = "0.0.99"
 authors = ["Matt Corallo"]
-license = "Apache-2.0"
+license = "MIT OR Apache-2.0"
 repository = "https://github.com/rust-bitcoin/rust-lightning/"
 description = """
 A Bitcoin Lightning library in Rust.
@@ -11,21 +11,36 @@ Still missing tons of error-handling. See GitHub issues for suggested projects i
 """
 
 [features]
-fuzztarget = ["bitcoin/fuzztarget"]
+allow_wallclock_use = []
+fuzztarget = ["bitcoin/fuzztarget", "regex"]
+# Internal test utilities exposed to other repo crates
+_test_utils = ["hex", "regex", "bitcoin/bitcoinconsensus"]
 # Unlog messages superior at targeted level.
 max_level_off = []
 max_level_error = []
 max_level_warn = []
 max_level_info = []
 max_level_debug = []
+# Allow signing of local transactions that may have been revoked or will be revoked, for functional testing (e.g. justice tx handling).
+# This is unsafe to use in production because it may result in the counterparty publishing taking our funds.
+unsafe_revoked_tx_signing = []
+unstable = []
+no_std = ["hashbrown"]
 
 [dependencies]
-bitcoin = "0.23"
+bitcoin = "0.26"
 
-[dev-dependencies.bitcoin]
-version = "0.23"
-features = ["bitcoinconsensus"]
+hashbrown = { version = "0.11", optional = true }
+hex = { version = "0.3", optional = true }
+regex = { version = "0.1.80", optional = true }
 
 [dev-dependencies]
 hex = "0.3"
-rand = "0.4"
+regex = "0.1.80"
+
+[dev-dependencies.bitcoin]
+version = "0.26"
+features = ["bitcoinconsensus"]
+
+[package.metadata.docs.rs]
+features = ["allow_wallclock_use"] # When https://github.com/rust-lang/rust/issues/43781 complies with our MSVR, we can add nice banners in the docs for the methods behind this feature-gate.