Use hashbrown replacements for std equivalents
[rust-lightning] / lightning / Cargo.toml
index affe46e3d03e2606bc58ea2a74c9b8e7feb4bbc5..71d85872398037881d5cc46c3f0ea8316b7c247c 100644 (file)
@@ -25,10 +25,12 @@ max_level_debug = []
 # This is unsafe to use in production because it may result in the counterparty publishing taking our funds.
 unsafe_revoked_tx_signing = []
 unstable = []
+no_std = ["hashbrown"]
 
 [dependencies]
 bitcoin = "0.26"
 
+hashbrown = { version = "0.11", optional = true }
 hex = { version = "0.3", optional = true }
 regex = { version = "0.1.80", optional = true }