Rename no_std feature to no-std
[rust-lightning] / lightning / Cargo.toml
index 73be5fff34da17f17dca0b213587418cf2bdbf08..8580a53a3f88bf87bc698de0fed906a881dfa376 100644 (file)
@@ -1,6 +1,6 @@
 [package]
 name = "lightning"
-version = "0.0.13"
+version = "0.0.99"
 authors = ["Matt Corallo"]
 license = "MIT OR Apache-2.0"
 repository = "https://github.com/rust-bitcoin/rust-lightning/"
@@ -26,19 +26,32 @@ max_level_debug = []
 unsafe_revoked_tx_signing = []
 unstable = []
 
+no-std = ["hashbrown", "bitcoin/no-std", "core2/alloc"]
+std = ["bitcoin/std"]
+
+default = ["std"]
+
 [dependencies]
-bitcoin = "0.26"
+bitcoin = { version = "0.27", default-features = false, features = ["secp-recovery"] }
+# TODO remove this once rust-bitcoin PR #637 is released
+secp256k1 = { version = "0.20.2", default-features = false, features = ["alloc"] }
 
+hashbrown = { version = "0.11", optional = true }
 hex = { version = "0.3", optional = true }
 regex = { version = "0.1.80", optional = true }
 
+core2 = { version = "0.3.0", optional = true, default-features = false }
+
 [dev-dependencies]
 hex = "0.3"
 regex = "0.1.80"
+# TODO remove this once rust-bitcoin PR #637 is released
+secp256k1 = { version = "0.20.2", default-features = false, features = ["alloc"] }
 
 [dev-dependencies.bitcoin]
-version = "0.26"
-features = ["bitcoinconsensus"]
+version = "0.27"
+default-features = false
+features = ["bitcoinconsensus", "secp-recovery"]
 
 [package.metadata.docs.rs]
 features = ["allow_wallclock_use"] # When https://github.com/rust-lang/rust/issues/43781 complies with our MSVR, we can add nice banners in the docs for the methods behind this feature-gate.