Actual no_std support
[rust-lightning] / lightning / Cargo.toml
index 20a6460d62dfec24bfe84d7aaaf823395e5912fd..8bbdfe95a3ebdc138916e435bae85a1f0a3380e7 100644 (file)
@@ -1,8 +1,8 @@
 [package]
 name = "lightning"
-version = "0.0.11"
+version = "0.0.99"
 authors = ["Matt Corallo"]
-license = "Apache-2.0"
+license = "MIT OR Apache-2.0"
 repository = "https://github.com/rust-bitcoin/rust-lightning/"
 description = """
 A Bitcoin Lightning library in Rust.
@@ -11,7 +11,10 @@ Still missing tons of error-handling. See GitHub issues for suggested projects i
 """
 
 [features]
-fuzztarget = ["bitcoin/fuzztarget"]
+allow_wallclock_use = []
+fuzztarget = ["bitcoin/fuzztarget", "regex"]
+# Internal test utilities exposed to other repo crates
+_test_utils = ["hex", "regex", "bitcoin/bitcoinconsensus"]
 # Unlog messages superior at targeted level.
 max_level_off = []
 max_level_error = []
@@ -21,14 +24,33 @@ max_level_debug = []
 # Allow signing of local transactions that may have been revoked or will be revoked, for functional testing (e.g. justice tx handling).
 # This is unsafe to use in production because it may result in the counterparty publishing taking our funds.
 unsafe_revoked_tx_signing = []
+unstable = []
+
+no_std = ["hashbrown", "bitcoin/no-std", "core2/alloc"]
+std = ["bitcoin/std"]
+
+default = ["std"]
 
 [dependencies]
-bitcoin = "0.23"
+bitcoin = { version = "0.27", default-features = false, features = ["secp-recovery"] }
+# TODO maybe bitcoin no-std should pull in this feature?
+secp256k1 = { version = "0.20.2", default-features = false, features = ["alloc"] }
 
-[dev-dependencies.bitcoin]
-version = "0.23"
-features = ["bitcoinconsensus"]
+hashbrown = { version = "0.11", optional = true }
+hex = { version = "0.3", optional = true }
+regex = { version = "0.1.80", optional = true }
+
+core2 = { version = "0.3.0", optional = true, default-features = false }
 
 [dev-dependencies]
 hex = "0.3"
 regex = "0.1.80"
+secp256k1 = { version = "0.20.2", default-features = false, features = ["alloc"] }
+
+[dev-dependencies.bitcoin]
+version = "0.27"
+default-features = false
+features = ["bitcoinconsensus", "secp-recovery"]
+
+[package.metadata.docs.rs]
+features = ["allow_wallclock_use"] # When https://github.com/rust-lang/rust/issues/43781 complies with our MSVR, we can add nice banners in the docs for the methods behind this feature-gate.