Bump dependencies to bitcoin 0.27 and bech32 0.8
[rust-lightning] / lightning / Cargo.toml
index 20a6460d62dfec24bfe84d7aaaf823395e5912fd..9a2861d6927da1969955c7b01f06877e5c95dafa 100644 (file)
@@ -1,8 +1,8 @@
 [package]
 name = "lightning"
-version = "0.0.11"
+version = "0.0.99"
 authors = ["Matt Corallo"]
-license = "Apache-2.0"
+license = "MIT OR Apache-2.0"
 repository = "https://github.com/rust-bitcoin/rust-lightning/"
 description = """
 A Bitcoin Lightning library in Rust.
@@ -11,7 +11,10 @@ Still missing tons of error-handling. See GitHub issues for suggested projects i
 """
 
 [features]
-fuzztarget = ["bitcoin/fuzztarget"]
+allow_wallclock_use = []
+fuzztarget = ["bitcoin/fuzztarget", "regex"]
+# Internal test utilities exposed to other repo crates
+_test_utils = ["hex", "regex", "bitcoin/bitcoinconsensus"]
 # Unlog messages superior at targeted level.
 max_level_off = []
 max_level_error = []
@@ -21,14 +24,27 @@ max_level_debug = []
 # Allow signing of local transactions that may have been revoked or will be revoked, for functional testing (e.g. justice tx handling).
 # This is unsafe to use in production because it may result in the counterparty publishing taking our funds.
 unsafe_revoked_tx_signing = []
+unstable = []
+
+no_std = ["hashbrown", "bitcoin/no-std"]
+std = ["bitcoin/std"]
+
+default = ["std"]
 
 [dependencies]
-bitcoin = "0.23"
+bitcoin = "0.27"
 
-[dev-dependencies.bitcoin]
-version = "0.23"
-features = ["bitcoinconsensus"]
+hashbrown = { version = "0.11", optional = true }
+hex = { version = "0.3", optional = true }
+regex = { version = "0.1.80", optional = true }
 
 [dev-dependencies]
 hex = "0.3"
 regex = "0.1.80"
+
+[dev-dependencies.bitcoin]
+version = "0.27"
+features = ["bitcoinconsensus"]
+
+[package.metadata.docs.rs]
+features = ["allow_wallclock_use"] # When https://github.com/rust-lang/rust/issues/43781 complies with our MSVR, we can add nice banners in the docs for the methods behind this feature-gate.